phpstudy已切换php7.3后composer安装 laravel/jetstream依然提示php版本为版本低问题解决方法

Laravel  /  管理员 发布于 6个月前   151

laravel8出来了所以我想测一下jetstream怎么个好法,就有了标题的问题

我安装的时候php版本是7.2+,后面一下laravel8也composer了下来

然后composer require laravel/jetstream 提示版本问题,低了,我一看还是原来的旧版本

laravel/jetstream at version has a php xxx

我在cmd上php -v 一看确实是7.2

我想起新的7.3环境变量没有加,赶紧添加上

右击电脑->属性->系统设置->高级->环境变量,找到path然后修改之前的php路径为7.3目录
比如我这里是:
D:\phpStudy\php\php-7.3.22-nts

把cmd关闭重新打开 php -v 正常了(注意:cmd一定要关闭重新打开不然环境变量不会生效)

1.png

好了正常了

解决方法:切换完新的php注意检查环境变量是否添加,不然就会指向原来添加过的旧版本

正在下载中....

请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!

该博客于2020-9-28日,后端基于laravel8框架开发
前端页面使用Bootstrap可视化布局系统自动生成

是我仿的原来我的TP5框架写的博客,比较粗糙,底下是入口
侯体宗的博客

      订阅博客周刊

文章归档

  • 2020-04         (5篇)
  • 2020-05         (6篇)
  • 2020-06         (7篇)
  • 2020-07         (8篇)
  • 2020-08         (4篇)
  • 2020-09         (7篇)
  • 2020-10         (6篇)
  • 2020-11         (6篇)
  • 2021-01         (4篇)
  • 2021-02         (2篇)
  • 2021-03         (1篇)
  • 2021-04         (1篇)

文章标签

友情链接

Auther ·HouTiZong
侯体宗的博客
© 2020 zongscan.com
版权所有ICP证 : 粤ICP备20027696号
PHP交流群 也可以扫右边的二维码
侯体宗的博客